Linuxhotel Wiki

Wie ging das nochmal?

Benutzer-Werkzeuge

Webseiten-Werkzeuge


lpi1:paketverwaltung

Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen gezeigt.

Link zu der Vergleichsansicht

Beide Seiten, vorherige Überarbeitung Vorherige Überarbeitung
Nächste Überarbeitung
Vorherige Überarbeitung
Nächste Überarbeitung Beide Seiten, nächste Überarbeitung
lpi1:paketverwaltung [2016/12/14 11:57]
127.0.0.1 Externe Bearbeitung
lpi1:paketverwaltung [2018/08/22 13:24]
127.0.0.1 Externe Bearbeitung
Zeile 29: Zeile 29:
 | |
 |Paket loeschen: (( auch das geht mit //​apt-get//,​ //yum//, //zypper// oder //yast// )) | |Paket loeschen: (( auch das geht mit //​apt-get//,​ //yum//, //zypper// oder //yast// )) |
-  dpkg --remove paket +  dpkg --remove ​<paket> 
-  dpkg --purge paket+  dpkg --purge ​<paket>
 | |
   rpm -e <​paket>​   rpm -e <​paket>​
Zeile 66: Zeile 66:
  
 ==== Abhängigkeiten (rpm) ==== ==== Abhängigkeiten (rpm) ====
-Von welchen Eigenschaften hängt das Paket //cups-libs// ab?+Von welchen Eigenschaften hängt das Paket //cups// ab?
   rpm -q --requires cups   rpm -q --requires cups
-Welche Eigenschaften stellt das Paket //cups-libs// anderen Paketen zur Verfügung?​ +Welche Eigenschaften stellt das Paket //systemd// anderen Paketen zur Verfügung?​ 
-  rpm -q --provides ​paket +  rpm -q --provides ​systemd 
-Welche Pakete hängen von der Eigenschaft ​//libcups.so.2// ab? +Welche Pakete hängen von //cups// ab? 
-  rpm -q --whatrequires ​libcups.so.2 +  rpm -q --whatrequires ​cups 
-Welches Paket stellt die Eigenschaft //libcups.so.2// zur Verfügung?​ +Welches Paket stellt die Eigenschaft //syslog// zur Verfügung?​ 
-  rpm -q --whatprovides ​libcups.so.2+  rpm -q --whatprovides ​syslog
  
 Bei //dpkg// sind Pakete direkt von anderen Paketen abhängig. Bei //dpkg// sind Pakete direkt von anderen Paketen abhängig.
Zeile 81: Zeile 81:
   * [[https://​mvogt.wordpress.com/​2014/​04/​|apt]] ist neu in debian 8.0 (jessie). Dieses Kapitel überarbeiten,​ sobald debian 7 nicht mehr supportet wird.    * [[https://​mvogt.wordpress.com/​2014/​04/​|apt]] ist neu in debian 8.0 (jessie). Dieses Kapitel überarbeiten,​ sobald debian 7 nicht mehr supportet wird. 
   * [[http://​dnf.readthedocs.org/​en/​latest/​cli_vs_yum.html|dnf]] statt yum, sobald das in CentOS ist.    * [[http://​dnf.readthedocs.org/​en/​latest/​cli_vs_yum.html|dnf]] statt yum, sobald das in CentOS ist. 
 +===== yum changelog =====
 +Changelog-Plugin installieren
 +  yum install yum-plugin-changelog
 +
 +Changelog abfragen
 +  yum changelog 2017-10-01 "​*openssh*"​
 +oder bei Update
 +  yum update <​paket>​ --changelog
 +
 ===== apt, yum und zypper ===== ===== apt, yum und zypper =====
 ^Funktion^Debian ^RedHat ^SuSE ^ ^Funktion^Debian ^RedHat ^SuSE ^
-|Repositories einbinden | ''/​etc/​apt/​sources.list''​ | ''/​etc/​yum.repos.d/​*.repo''​ | ''/​etc/​zypp/​repos.d/​*.repo''​ |+|Repositories einbinden | ''/​etc/​apt/​sources.list''​ \\ ''/​etc/​apt/​sources.list.d/​*.list''​ |  
 +  yum-config-manager 
 +oder ''/​etc/​yum.repos.d/​*.repo''​ | ''/​etc/​zypp/​repos.d/​*.repo''​ |
 |Repository-Daten aktualisieren| |Repository-Daten aktualisieren|
   aptitude update   aptitude update
Zeile 135: Zeile 146:
   zypper install paketname   zypper install paketname
 | |
-|Paket erneut installieren| ​TODO |+|Paket erneut installieren| ​apt-get install --reinstall paketname ​|
   yum reinstall paketname   yum reinstall paketname
 | TODO | | TODO |
lpi1/paketverwaltung.txt · Zuletzt geändert: 2021/11/02 22:36 (Externe Bearbeitung)