Linuxhotel Wiki

Wie ging das nochmal?

Benutzer-Werkzeuge

Webseiten-Werkzeuge


lpi1:paketverwaltung

Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen gezeigt.

Link zu der Vergleichsansicht

Beide Seiten, vorherige Überarbeitung Vorherige Überarbeitung
Nächste Überarbeitung
Vorherige Überarbeitung
lpi1:paketverwaltung [2013/07/01 12:48]
ingo_wichmann [apt, yum und zypper]
lpi1:paketverwaltung [2018/09/18 07:06]
ingo_wichmann [yast, y2pmsh, rug und zypper]
Zeile 29: Zeile 29:
 | |
 |Paket loeschen: (( auch das geht mit //​apt-get//,​ //yum//, //zypper// oder //yast// )) | |Paket loeschen: (( auch das geht mit //​apt-get//,​ //yum//, //zypper// oder //yast// )) |
-  dpkg --remove paket +  dpkg --remove ​<paket> 
-  dpkg --purge paket+  dpkg --purge ​<paket>
 | |
   rpm -e <​paket>​   rpm -e <​paket>​
 | |
 +
 +^Funktion ^Debian und Ubuntu ^RedHat, Fedora und SuSE (( OK, rpm ist auch für debian verfügbar, aber sollte da nur in besonderen Fällen eingesetzt werden )) |
 |Pakete nach Größe sortiert ausgeben: | |Pakete nach Größe sortiert ausgeben: |
   dpkg-query -W --showformat='​${Installed-Size} \   dpkg-query -W --showformat='​${Installed-Size} \
Zeile 49: Zeile 51:
 | |
   rpm -qac --dump | perl -naF'​\s+'​ -e 'print $F[0], $/ if -f $F[0] and not -l $F[0] and (split /\s+/, `md5sum $F[0]`)[0] ne $F[3]' ​   rpm -qac --dump | perl -naF'​\s+'​ -e 'print $F[0], $/ if -f $F[0] and not -l $F[0] and (split /\s+/, `md5sum $F[0]`)[0] ne $F[3]' ​
 +|
 +| Konfigurationsdatei wiederherstellen |
 +  cd /​var/​cache/​apt/​archives/​
 +  dpkg -i --force-confmiss dokuwiki_0.0.20120125b-2_all.deb
 | |
 | Zuletzt installierte Pakete anzeigen: | | Zuletzt installierte Pakete anzeigen: |
Zeile 60: Zeile 66:
  
 ==== Abhängigkeiten (rpm) ==== ==== Abhängigkeiten (rpm) ====
-Von welchen Eigenschaften hängt das Paket //cups-libs// ab?+Von welchen Eigenschaften hängt das Paket //cups// ab?
   rpm -q --requires cups   rpm -q --requires cups
-Welche Eigenschaften stellt das Paket //cups-libs// anderen Paketen zur Verfügung?​ +Welche Eigenschaften stellt das Paket //systemd// anderen Paketen zur Verfügung?​ 
-  rpm -q --provides ​paket +  rpm -q --provides ​systemd 
-Welche Pakete hängen von der Eigenschaft ​//libcups.so.2// ab? +Welche Pakete hängen von //cups// ab? 
-  rpm -q --whatrequires ​libcups.so.2 +  rpm -q --whatrequires ​cups 
-Welches Paket stellt die Eigenschaft //libcups.so.2// zur Verfügung?​ +Welches Paket stellt die Eigenschaft //syslog// zur Verfügung?​ 
-  rpm -q --whatprovides ​libcups.so.2+  rpm -q --whatprovides ​syslog
  
 Bei //dpkg// sind Pakete direkt von anderen Paketen abhängig. Bei //dpkg// sind Pakete direkt von anderen Paketen abhängig.
  
 ====== Repository basierte Paketverwaltung ====== ====== Repository basierte Paketverwaltung ======
 +TODO: 
 +  * [[https://​mvogt.wordpress.com/​2014/​04/​|apt]] ist neu in debian 8.0 (jessie). Dieses Kapitel überarbeiten,​ sobald debian 7 nicht mehr supportet wird. 
 +  * [[http://​dnf.readthedocs.org/​en/​latest/​cli_vs_yum.html|dnf]] statt yum, sobald das in CentOS ist. 
 +===== yum changelog =====
 +Changelog-Plugin installieren
 +  yum install yum-plugin-changelog
 +
 +Changelog abfragen
 +  yum changelog 2017-10-01 "​*openssh*"​
 +oder bei Update
 +  yum update <​paket>​ --changelog
 +
 ===== apt, yum und zypper ===== ===== apt, yum und zypper =====
 ^Funktion^Debian ^RedHat ^SuSE ^ ^Funktion^Debian ^RedHat ^SuSE ^
-|Repositories einbinden |  +|Repositories einbinden | ''/​etc/​apt/​sources.list''​ \\ ''/​etc/​apt/​sources.list.d/*.list''​ |  
-  ​apt-setup +  yum-config-manager 
-''/​etc/​apt/​sources.list''​ | ''/​etc/​yum.repos.d/​*.repo''​ | ''/​etc/​zypp/​repos.d/​*.repo''​ |+oder ''/​etc/​yum.repos.d/​*.repo''​ | ''/​etc/​zypp/​repos.d/​*.repo''​ |
 |Repository-Daten aktualisieren| |Repository-Daten aktualisieren|
   aptitude update   aptitude update
Zeile 83: Zeile 101:
 | |
   zypper refresh   zypper refresh
-| 
-|nach Updates suchen | 
-  apt-get -s update 
-| 
-  yum check-update 
-| 
-  zypper list-updates 
 | |
 |Updates einspielen | |Updates einspielen |
Zeile 104: Zeile 115:
 oder oder
   apt-get dist-upgrade   apt-get dist-upgrade
 +Ubuntu:
 +  do-release-upgrade
 | |
   yum upgrade   yum upgrade
Zeile 133: Zeile 146:
   zypper install paketname   zypper install paketname
 | |
 +|Paket erneut installieren| apt-get install --reinstall paketname |
 +  yum reinstall paketname
 +| TODO |
 |Paket entfernen| |Paket entfernen|
   aptitude remove paketname   aptitude remove paketname
Zeile 138: Zeile 154:
   apt-get [--purge] remove paketname   apt-get [--purge] remove paketname
 | |
-  yum remove paketname+  yum autoremove paketname 
 +
 +  zypper ​remove paketname
 | |
 |Paket für Datei ''​samba.schema''​ im Repository suchen| |Paket für Datei ''​samba.schema''​ im Repository suchen|
-  apt-file updateapt-file search samba.schema+  apt-file update 
 +  ​apt-file search samba.schema
  
   yum provides */​samba.schema   yum provides */​samba.schema
 | |
 +
 ==== Abhängigkeiten (dpkg und apt) ==== ==== Abhängigkeiten (dpkg und apt) ====
 Von welchen Paketen ist das Paket //cups// abhängig? Von welchen Paketen ist das Paket //cups// abhängig?
Zeile 151: Zeile 171:
   apt-cache rdepends cups   apt-cache rdepends cups
  
-==== yast, y2pmsh, rug und zypper ==== 
-YaST, y2pmsh, rug und zypper sind nur für SuSE verfügbar. 
- 
-^Funktion ^y2pmsh ( SuSE 9.2 bis 10.1 / SLES 9 & 10 ) (( nicht offiziell unterstützt - aber brauchbar )) ^rug ( SuSE 10.1 bis 10.2 / SLES 10 ) ^zypper ( ab SuSE 10.2) | 
-| Repositories einbinden |  
-  y2pmsh source --add http://​suse/​i386/​update/​10.1 
-oder 
-  y2pmsh source -a http://​suse/​i386/​update/​10.1 
- ​| ​ 
-  rug service-add -t zypp http://​suse/​i386/​update/​10.1 ​ 
-oder 
-  rug sa -t zypp http://​suse/​i386/​update/​10.1 ​ 
-| 
-  zypper service-add http://​suse/​i386/​update/​10.3 
-oder 
-  zypper service-add http://​suse/​i386/​update/​10.3 
-| 
-|Repository-Daten aktualisieren| 
-  ​ 
-| 
-  rug refresh 
-| 
-  zypper refresh 
-| 
-|Updates einspielen | 
-  y2pmsh upgrade 
-  y2pmsh commit 
-| 
-  rug update 
-| 
-  zypper update 
-| 
-|Nach Paketen suchen| 
-  y2pmsh search suchwort 
-| 
-  rug search suchwort 
-| 
-  zypper search suchwort 
-| 
-|Paketbeschreibung anzeigen:| 
-  y2pmsh show paketname 
-| 
-  rug info paketname 
-| 
-  zypper info paketname 
-| 
-|Paket installieren| 
-  y2pmsh isc paketname 
-oder 
-  y2pmsh install paketname 
-  y2pmsh solve 
-  y2pmsh commit 
-| 
-  rug install paketname 
-| 
-  zypper install paketname 
-| 
-|Paket entfernen| 
-  y2pmsh remove paketname 
-  y2pmsh solve 
-  y2pmsh commit 
-| 
-  rug remove paketname 
-| 
-  zypper remove paketname 
-| 
- 
-Die Paketverwaltung von YaST baut bis SuSE 10.0 / SLES 9 auf dem Programm ''​y2pmsh''​ auf, daß man hier auch an Stelle von yast benutzen kann. ''​y2pmsh''​ hat auch einen interaktiven Modus: einfach starten, und die oben angegebenen Befehle funktionieren incl. Tab-Completion 
- 
-y2pmsh/​YaST/​rug/​zypper bietet die Möglichkeit verschiedene Repositories einzubinden. Eine Liste verfügbarer Repositories findet sich hier: http://​www.opensuse.org/​Additional_YaST_Package_Repositories 
  
-Hier ist beschrieben,​ wie man ein lokales Repository für YaST erstellt: http://​en.opensuse.org/​Network_Installation_Source 
 ===== Neues Repository samt Schlüssel zu Debian hinzufügen ===== ===== Neues Repository samt Schlüssel zu Debian hinzufügen =====
 Adresse des Repositories zu ''/​etc/​apt/​sources.list.d''​ hinzufügen. Adresse des Repositories zu ''/​etc/​apt/​sources.list.d''​ hinzufügen.
Zeile 254: Zeile 203:
  
 ===== openSuSE ===== ===== openSuSE =====
-  * [[http://dewiki.opensuse.org/​Paket_Repositories]]+  * [[https://de.opensuse.org/​Paket_Repositories]]
  
 ====== rpm ====== ====== rpm ======
Zeile 270: Zeile 219:
   rpm2cpio nxclient-1.5.0-113.i386.rpm | cpio -id ./​usr/​NX/​share/​keys/​server.id_dsa.key   rpm2cpio nxclient-1.5.0-113.i386.rpm | cpio -id ./​usr/​NX/​share/​keys/​server.id_dsa.key
  
-===== bash_completion ===== 
-Pakete: 
- 
-''​bash_completion''​ ( SuSE ) 
- 
-''​bash''​ ( Debian ) 
- 
-Hilfreich beim Eingeben der Befehle, Optionen und Paketnamen ​ 
  
-Aktivieren über den Befehl: 
-  . /​etc/​bash_completion 
   ​   ​
  
lpi1/paketverwaltung.txt · Zuletzt geändert: 2021/11/02 22:36 (Externe Bearbeitung)